Friday, November 19, 2010

Jailbreak iOS 4.2.1 GM On iPhone 4, 3GS, 3G and iPod Using Redsn0w 0.9.6b2

In the previous post I informed about the release of iOS 4.2.1 GM for iPhone & iPod touches. And apparently we can jailbreak the iOS 4.2.1 GM using Redsn0w 0.9.6b2, of course this is a wonderful news to those who have upgraded their iOS.

Jailbreak iOS 4.2.1 On iPhone 3G, 4 iPod & iPad

But there is the unwanted news along with the wonderful one, because Cydia store will not be used albeit your iOS 4.2.1 is jailbroken, if you run Cydia - it will crash. This is happening because Apple deliberately has altered the private APIs that Cydia had been used.

Thus, even thought you managed to jailbreak the iOS 4.2.1 for your iDevices it won't benefit you much, each time you wish to download and install the jailbreak apps from Cydia, you need to install is manually with SSH.

But if you insist to jailbreak anyway, these are the requirements you need to have:
After you have met the above requirements you can further visit this link: to jailbreak iOS 4.2.1 GM For iPhone 3G, 3GS, 4 & iPod touch With Redsn0w 0.9.6b2


Post a Comment